Оборудование Cisco. Балансировка BGP между двумя провайдерами.

Описана балансировка BGP на оборудовании Cisco для двух провайдеров.



Полезная ссылка: О нас и наших клиентах

 

Балансировка BGP маршрутизаторы Cisco.

Данная статья описывает типичную ситуацию, с которой может встретиться администратор, который располагает «собственную» зарегистрированную автономную систему (AS) вместе с внешней сетью, два подключения к различным Интернет провайдеров, а также маршрутизатор Cisco с ограниченными ресурсами памяти.

Рассмотрим следующий сценарий, в наличии имеем:

1. Интернет каналы с провайдером ISP-1, 10 Мбит / с, peer net 192.168.10.0/30, AS 65510;
2. Интернет каналы с провайдером ISP-2, 50 Мбит / с, peer net 172.16.10.0/30, AS 65520;
3. Наша AS 65500 и сеть 10.10.10.0/24.

Нам нужно, чтобы в штатном режиме Интернет трафик проходил в обоих направлениях только через основной канал (через провайдера ISP-2), а соединение через провайдера ISP-1 было резервным, трафик через который пойдет лишь при условии падения основного. Необходимо настроить балансировку BGP. В данной статье используются команды маршрутизатора Cisco.

 

Полезная ссылка: Контакты сетевых админисраторов по настройке оборудования Cisco


Главное для типового настройки BGP - это принимать нужные вам анонсы от провайдера, и корректно «рассказать» о своей сети или сети другим BGP участникам. Именно эта тривиальная конфигурация BGP multihoming поможет вам организовать пиринговые с соседними автономными системами (с Интернет провайдерами) при этом не даст вашей автономной системе стать транзитной (есть такой, которая через себя будет пропускать Интернет трафик от одного провайдера к другому). Идея состоит в том, что вы получаете от провайдера только информацию о маршруте по умолчанию, в результате чего BGP таблица разрастается до невероятных размеров (full view), что в свою очередь сохраняет ресурсы вашего маршрутизатора.

По анонсов вашей сети внешним автономным системам, то здесь немного сложнее. В этом случае могут возникнуть негативные ситуации: асинхронные маршруты (пакеты выходят через один канал, а входят в вашу AS через другой канал), нежелательный входящий трафик на резервном канале ограниченной пропускной способности (в нашем примере ISP-1), что в свою очередь может привести к ухудшению качества доступа в Интернет доступа к вашим сервисов в Интернете. Для решения этих проблем существует много методов и схем, среди них: изменение значения атрибута AS-PATH путем добавления номера своей AS в список уже существующих (удлинение атрибута AS-PATH), настройки значения атрибута community предварительно согласовав его с имеющимися провайдерами, выборочные анонсы своей сети за счет использования Cisco IOS функции EXIST-MAP и NON-EXIST-MAP. Первый метод прост, но в большинстве случаев этот атрибут не учитывается на стороне провайдера. Второй случай более реалистичный, именно его мы рассмотрим в примере.

 


Рассмотрение третьей схемы требует более детального анализа, в нескольких словах, интерес данной идея заключается в том, что вы можете осуществлять выборочный BGP анонс в нужное для вас канал и в нужное время. Рассмотрим более подробно наш случай об объявлении нашей сети своим соседям. Для этого мы воспользуемся атрибутом community. Сам по себе этот атрибут не может влиять на BGP процесс выбора маршрута, но может использоваться как служебный тег в сообщениях о вашу сеть к провайдеру. Опираясь на значение этого тега ваш провайдер может применить соответствующие политики маршрутизации в своей сети (например применить атрибут LOCAL_PREF), тем самым изменив приоритетность вхождения Интернет трафика в вашу автономную систему через канал этого провайдера. То есть, в нашем примере, обратные пакеты не возвращаться через резервный канал (ISP-1) при условии, что основной канал доступа (ISP-2) остается рабочим. Таким образом мы можем избавиться вышеприведенных проблем прохождения трафика.

Рассмотрим пример нашей конфигурации:
interface GigabitEthernet0/0
description <>
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet0/1
description <>
ip address 192.168.10.1 255.255.255.252
!
interface GigabitEthernet0/2
description <>
ip address 172.16.10.1 255.255.255.252
!
router bgp 65500
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
neighbor 172.16.10.2 remote-as 65520
neighbor 172.16.10.2 description ISP-2
neighbor 172.16.10.2 weight 150 !!--- Делаем преимущество нашему трафику через нашу
!!--- автономую систему
neighbor 172.16.10.2 route-map ISP-2_in in
neighbor 172.16.10.2 route-map ISP-2_out out
neighbor 192.168.10.2 remote-as 65510
neighbor 192.168.10.2 description ISP-1
neighbor 192.168.10.2 weight 25
neighbor 192.168.10.2 route-map ISP-1_in in
neighbor 192.168.10.2 route-map ISP-1_out out
no auto-summary
!
ip as-path access-list 10 permit ^$
!
ip prefix-list DEFAULT_IN seq 5 permit 0.0.0.0/0
!
!--- Эти роут-мапы анонсируют те сети, которые созданы в локальной АС то есть 10.10.10.0/24
!
route-map ISP-1_out permit 10
match as-path 10
set community 65200:80
!
route-map ISP-2_out permit 10
match as-path 10
!
route-map ISP-1_in permit 10
match ip address prefix-list DEFAULT_IN
!
!
route-map ISP-2_in permit 10
match ip address prefix-list DEFAULT_IN

Как практика показывает, что в зависимости от выбранной методики процесс управления своими анонсами есть не всегда прогнозируемым и не всегда от вас зависит.

Другие статьи:
Настройка BGP на оборудовании Juniper

Услуги по настройке протокола BGP на сетевом оборудовании



Обновлен 12 июл 2014. Создан 28 мар 2013



  Комментарии       
Имя или Email


При указании email на него будут отправляться ответы
Как имя будет использована первая часть email до @
Сам email нигде не отображается!
Зарегистрируйтесь, чтобы писать под своим ником

____

______
Яндекс.Метрика