Настройка VPN между оборудованием MikroTik и Cisco

настройка Cisco 1700, настройка MikroTik RB450G, MikroTik VPN, Cisco 1700 VPN



Полезная ссылка: О нас и наших клиентах

 

 

Настройка VPN между MikroTik и Cisco


В данной статье используется оборудование Cisco 1700 серии и MikroTik RB450G. В главном офисе Cisco 1700 серии, на периферии MikroTik RB450G.

В данной конфигурации настройки протокола PPTP для VPN, поскольку мы запретили IPSec в главном офисе в сетевых политиках.

 

Главный офис внутренний диапазон адерсов: 10.1.202.x/24

Главный офис диапазон публичных адресов : 192.168.90.1

Удаленный офис внутренний диапазон адресов : 10.1.101.x/24 

Удаленный офис диапазон публичных адресов: 192.168.80.1

 

 

Настройки Cisco 1700  для соединения с MikroTik RB450G через VPN:  

 

aaa new-model
!
aaa authentication ppp default local
!
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!
username pptp_branch password 7 050S070018486547832107
!
interface Virtual-Template1
ip address 10.0.100.1 255.255.255.0
peer default ip address pool PPTP_POOL
no keepalive
ppp encrypt mppe 128 required
ppp authentication ms-chap-v2
!
ip local pool PPTP_POOL 10.0.100.2
ip route 10.1.101.0 255.255.255.0 10.0.100.2

 

Настройки MikroTik RB450G для соединения с Cisco 1700  через VPN:

Полезная ссылка: Консультация по настройке оборудования Cisco Mikrotik

 

 

/ppp profile
set default change-tcp-mss=yes name=default only-one=default use-compression=default
    use-encryption=default use-mpls=default use-vj-compression=default
set default-encryption change-tcp-mss=yes name=default-encryption only-one=default
    use-compression=default use-encryption=yes use-mpls=default use-vj-compression=
    default

/interface pptp-client
add add-default-route=no allow=mschap2 connect-to=192.168.90.18 dial-on-demand=no
    disabled=no max-mru=1024 max-mtu=1024 mrru=disabled name=pptp-branch password=
    ThisIsPassword profile=default-encryption user=pptp_branch

/ip route
add disabled=no distance=1 dst-address=10.1.202.0/24 gateway=10.0.100.1 scope=30
    target-scope=10

 

Эта конфигурация вынудит удаленный маршрутизатор MikroTik RB450G использовать только один IP-адрес (10.0.100.2), и основной маршрутизатор Cisco 1700 направляет все пакеты на данный адрес.


 

Ключевые пункты:

Удостоверьтесь пароль, который Вы устанавливаете для PPTP, не MD5 на маршрутизаторе Cisco.

Если туннель часто разъединяется, проверьте значение MTU.

 

Полезные ссылки:


Настройка оборудования MikroTik

Настройка оборудования Cisco 



Обновлен 12 июл 2014. Создан 11 апр 2013



  Комментарии       
Имя или Email


При указании email на него будут отправляться ответы
Как имя будет использована первая часть email до @
Сам email нигде не отображается!
Зарегистрируйтесь, чтобы писать под своим ником

____

______
Яндекс.Метрика