Настройка Cisco GRE через Site to site VPN.




Полезная ссылка: О нас и наших клиентах

 

Настройка Cisco GRE через Site to site VPN.


В данной статье хочу рассказать вам о настройке Cisco GRE туннеля для Site to site VPN.


Первое что нам необходимо сделать так это сделать первую фазу ISAKMP для обеспечения безопасности связи через IP.


crypto isakmp policy 1

encr 3des

hash md5

authentication pre-share

crypto isakmp key cisco123 address 10.0.0.18

 


Вторая фаза будет использоваться, чтобы договориться о безопасной связи. Для этого необходимо применить политику к  интерфейсу. Создадим список доступа в соответствии с трафиком GRE туннель, и, наконец, настроим на Cisco туннель GRE.


crypto ipsec transform-set ASA esp-des esp-sha-hmac

!

crypto map SDM 1 ipsec-isakmp

set peer 10.0.0.18

set transform-set ASA

match address 100

!

access-list 100 permit gre host 10.0.0.14 host 10.0.0.18

!

interface FastEthernet0/0

ip address 10.0.0.14 255.255.255.252

crypto map SDM

Конфигурация туннеля GRE -  straight forward.


Полезная ссылка: Консультация по настройке оборудования Cisco


interface Tunnel1

ip unnumbered Loopback0

tunnel source FastEthernet0/0

tunnel destination 10.0.0.18

Введем подобную конфигурацию на другом роутере.

crypto isakmp policy 1

encr 3des

hash md5

authentication pre-share

crypto isakmp key cisco123 address 10.0.0.14

!

!

crypto ipsec transform-set ASA esp-des esp-sha-hmac

!

crypto map SDM 1 ipsec-isakmp

set peer 10.0.0.14

set transform-set ASA

match address 100

interface Tunnel1

ip unnumbered Loopback0

tunnel source FastEthernet0/0

tunnel destination 10.0.0.14

!

interface FastEthernet0/0

ip address 10.0.0.18 255.255.255.252

speed 100

full-duplex

crypto map SDM

access-list 100 permit gre host 10.0.0.18 host 10.0.0.14

 

В этом примере, мы создали туннель IPsec между двумя физическими интерфейсами, и выбрали трафика GRE и настроили туннель GRE на оборудовании Cisco.


Также есть другой метод настройки Cisco GRE туннеля, где политика IPsec будет определена и интерфейс GRE туннеля будет защищен. Для этого нам необходимо ввести небольшие изменения в конфигурацию, как показано ниже.


Фаза 1 настроим transport-set в режим “mode transport”.  Там не будет crypto Map и туннель будет защищен.


crypto ipsec transform-set TS esp-3des esp-md5-hmac

R1 (cfg-crypto-trans)# mode transport

tunnel int 1

tunnel protection ipsec profile protect-gre

для завершения настройки безопасного GRE туннеля  из IPsec сделаем следующее:

crypto isakmp policy 1

encr 3des

hash md5

authentication pre-share

crypto isakmp key cisco123 address 10.0.0.14

!

!

crypto ipsec transform-set ASA esp-des esp-sha-hmac

mode transport

!

interface Tunnel1

ip unnumbered Loopback0

tunnel source FastEthernet0/0

tunnel destination 10.0.0.14

tunnel protection ipsec profile ASA

!

 

Статья взята из:

http://jemnettechnologies.blogspot.com/2013/08/configuring-cisco-gre-over-site-to-site.html



Обновлен 12 июл 2014. Создан 20 авг 2013



  Комментарии       
Имя или Email


При указании email на него будут отправляться ответы
Как имя будет использована первая часть email до @
Сам email нигде не отображается!
Зарегистрируйтесь, чтобы писать под своим ником

____

______
Яндекс.Метрика