Cisco настройка PPPoE

Cisco настройка PPPoE на Cisco



Полезная ссылка: О нас и наших клиентах

 

 

 

И так  сегодняшней статье вы рассмотрим конфигурацию и настройку протокола PPPoE на оборудовании Cisco.

 

PPPoE (Point-to-point protocol over Ethernet) — это протокол (сетевой) канального уровня, который передает кадры PPP через технологию Ethernet. На данный момент в мире в основном используется xDSL-сервисами. Данный протокол предоставляет дополнительные возможности настойки аутентификация, сжатие данных, шифрование. На оборудовании cisco  настройка протокола pppoe не такое сложное, как кажется на первый взгляд.

 

Стандартное MTU протокола ниже (1492 байт), чем на стандартном Ethernet (1500 байт), что иногда вызывает проблемы с плохо настроенными межсетевыми экранами. PPPoE — это туннелирующий протокол, который позволяет настраивать (или инкапсулировать) IP, или другие протоколы, которые настраиваются на PPP, через соединения Ethernet, но с программными возможностями PPP соединений, и поэтому используется для виртуальных «звонков» на соседнюю Ethernet-машину и устанавливает соединение точка-точка, которое используется для транспортировки IP-пакетов, работающее с возможностями PPP.

Настраиваем на маршрутизаторе Cisco протокол pppoe :


 

Сконфигурируем диапазон IP которые будут раздаваться клиентам.

Server(config)#ip local pool MyPool 10.0.0.1 10.0.0.10

Создадим пользователя и присвоим ему пароль

Server(config)#username test password 0 pass

 

Настройка PPPOE:

Server(config-if)#interface Virtual-Template1

Server(config-if)# ip address 10.0.0.138 255.255.255.0

Server(config-if)# ip virtual-reassembly

Server(config-if)# peer default ip address pool MyPool

Server(config-if)# ppp authentication pap callin

 

Назначим pppoe группу, в  global групп

Server(config)#bba-group pppoe global

Server(config-bba-group)# virtual-template 1

Server(config-bba-group)# sessions per-mac limit 3

Активируем pppoe группу для клиентов

Полезная ссылка: Консультация по настройке оборудования Cisco


Server(config)#interface FastEthernet0/0

Server(config-if)# pppoe enable group global

Сторона пользователя (cisco настройка pppoe):

 

Активируем pppoe на интерфейсе:

Client(config)#interface FastEthernet0/0

Client(config-if)# pppoe enable

Client(config-if)# pppoe-client dial-pool-number 1

Создадим dialer:

Client(config)#interface Dialer1

Client(config-if)# ip address negotiated

Client(config-if)# encapsulation ppp

Client(config-if)# dialer pool 1

Client(config-if)# ppp pap sent-username test password 0 pass

С маршрутизируем весь трафик PPPOE интерфейс

Client(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

Проверяем подключения PPPOE на Cisco.

Server# show users

   Interface           User      Mode    Idle        Peer Address

  Vi1.1                    test        PPPoE   -              10.0.0.2

Проверяем есть ли соединение клиента с миром:

Client#ping 8.8.8.8

 Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 124/148/184 ms



Обновлен 12 июл 2014. Создан 20 авг 2013



  Комментарии       
Всего 1, последний 2 мес назад
stas 12 июл 2017 ответить
Если правило pppoe enable group global написать только на физическом порту, будет ли оно работать на сабинтерфейсах
Имя или Email


При указании email на него будут отправляться ответы
Как имя будет использована первая часть email до @
Сам email нигде не отображается!
Зарегистрируйтесь, чтобы писать под своим ником

____

______
Яндекс.Метрика