Настройка Mikrotik OpenVPN с Windows 7 клиент




Полезная ссылка: О нас и наших клиентах

 

 

Сервер Mikrotik OpenVPN / Windows 7 клиент


Mikrotik сделали очень отличные и одновременно дешевые маршрутизаторы и установили мощную RouterOS которая предоставляет много возможностей пользователю.


Это инструкция о том, как установить и настроить клиент / сервер VPN с помощью Mikrotik (с RouterOS LV 4) в качестве VPN-сервера и Windows 7, клиентов.


Вам для настройки Mikrotik OpenVPN понадобится:

Последняя версия OpenVPN  для ОС Windows и Linux

A Mikrotik RouterBOARD  или ПК под управлением RouterOS с лицензии 4 уровня, уже с настроенной в качестве основного маршрутизатора.

Полезная ссылка: Консультация и заказ настройки Микротик

Модули безопасности, установленные на RouterOS

Ubuntu для  создания сертификатов

 

  1. Создание сертификаты, необходимые как OpenVPN используется SSL для обеспечения безопасности:

Прежде всего, избегайте метод, описанный в Mikrotik Wiki , который использует CAcert.org. Вместо этого используйте easy-rsa, которая поставляется с OpenVPN. Мне было проще использовать Ubuntu VM на VirtualBox, как осуществление easy-rsa окон не работает хорошо для меня:

 

Отредактируйте файл VARS в соответствии с настройками.

Не переименовать whichopenssl.cnf файл в openssl.cnf!


sudo source vars

./clean-all

build-ca

build-key-server server


а также предоставить необходимую информацию логин/ пароль, где это необходимо. После этого вы получите файл ca.crt, server.key и server.crt .

 

  1. Импортируйте файли на ваш RouterOS маршрутизатор:

Скопируйте server.crt и server.key откройте Winbox, перейдите в файлы и вставьте. Все просто.

Откройте термінал и импорт сертификатов:       

/certificate import file-name=server.crt

/certificate import file-name=server.key

 

При запросе, укажите пароль, используемый при создании сертификата.

 

Настройка Mikrotik OpenVPN

  1. Создайте пул IP для пользователей VPN:

/ip pool add name=ovpn-pool ranges=172.21.0.10-172.21.0.20

/ppp profile add local-address=172.21.0.1 name=ovpn remote-address=ovpn-pool

/ppp secret add name=user password=pass profile=ovpn service=ovpn

/interface ovpn-server server set default-profile=ovpn enabled=yes mode=ethernet netmask=24 require-client-certificate=no certificate=cert1

Заменитє имя пользователя и пароль с вашими учетные данными для входа.

Вы можете использовать любой диапазон IP, но лучше использовать IP  которие редко встречается при использовании VPN.

  1. Настройка клиента:

Скопируйте файл client.ovpn в папку конфигурации установки OpenVPN.

Также скопировать ca.crt созданный ранее. Откройте его с помощью Notepad + + или другим текстовым редактором. В нем написать следующее:

            dev tap

               remote your-external-ip-address

               proto tcp-client

               tls-client

               ca ca.crt

               auth-user-pass

               pull

               nobind

               persist-key

               resolv-retry infinite

               verb 3

               script-security 2 system

               route-up “route add LAN-IP mask 255.255.255.0 172.21.0.1″

               auth-nocache

 

который использует интерфейс моста для подключения к Mikrotik и аутентификации с использованием ранее созданных регистрационных данных.


Система script-security 2 используется, чтобы позволить успешно прокинуть маршрут по умолчанию для клиентов маршрутизации, когда они подключается. Кроме того, чтобы это работало в любое время, вам придется открыть OpenVPN GUI от имени администратора.


mikrotik openvpn client
mikrotik vpn pptp
mikrotik vpn client
vpn между mikrotik
site +to site vpn mikrotik
mikrotik vpn l2tp
mikrotik ovpn server

Если маршрут умолчанию запрещено, вручную поставить на клиентском ПК VPN будет работать, но будет практически бесполезным, так как компьютер не будет знать, что делать с запросами от вашей локальной сети на другой стороне VPN. К сожалению, реализация RouterOS не может впрокинуть маршруты по VPN, поэтому мы вынуждены прибегать к описанному выше способу (который работает очень хорошо, он также снимает маршрут после отключения).

  1. Он также работает с портативными версиями OpenVPN, таким образом, все, что вам нужно, это USB с портативным OpenVPN на нем, клиент конфиг и файл ca.crt.


Обновлен 12 июл 2014. Создан 01 апр 2014



  Комментарии       
Имя или Email


При указании email на него будут отправляться ответы
Как имя будет использована первая часть email до @
Сам email нигде не отображается!
Зарегистрируйтесь, чтобы писать под своим ником

____

______
Яндекс.Метрика